Alechx's Blog

Just keep on …

Archive for aprile 2009

Installazione VirtualBox: impossibile soddisfare le dipendenze

leave a comment »

Ciao a tutti, non so a quanti di voi sarà capitato di installare virtualbox ultimamente sulle vostre macchine linux.

Bene, a me ieri pacman mi ha restituito il seguente output:
bash-3.2$ sudo pacman -S virtualbox-ose
risoluzione delle dipendenze in corso...
errore: impossibile risolvere "kernel26<2.6.29", una dipendenza di "virtualbox-modules"
errore: impossibile eseguire l'operazione richiesta (impossibile soddisfare le dipendenze)
:: virtualbox-modules: richiede kernel26<2.6.29

Ho pensato bene si superare questo problema scaricando il file:
http://repo.archlinux.fr/i686/virtualbox_bin-2.2.0-1.pkg.tar.gz
e lanciando il solito comando:
#pacman -U virtualbox_bin-2.2.0-1.pkg.tar.gz

Vi riporto qui sotto importanti consigli di pacman.
—————————————————————————
IMPORTANT NOTES:

– Run “vbox_build_module” as root every time your kernel is upgraded, to compile the module for the new kernel version.
– Add your user to the vboxusers group:
gpasswd -a USERNAME vboxusers
– Add “vboxdrv” to the MODULES array in your “/etc/rc.conf”
– Add “vboxnetflt” to MODULES if you want Host Interface networking.
– Add the following line to “/etc/fstab” if you want the vboxusers to have permission to emulate USB devices:
none /proc/bus/usb usbfs auto,busgid=108,busmode=0775,devgid=108,devmode=0664 0 0
—————————————————————————

Naturalmente è possibile anche fare l’installazione con:
$ yaourt -S virtualbox_bin

😀 alla prossima!

Written by alechx

22 aprile 2009 at 10:39

Pubblicato su archlinux, informatica

Tagged with , , ,

Aggiornamento di xorg-server alla versione 1.6

with 2 comments

Per quanti di voi usano ArchLinux e hanno provato a fare l’aggioramento del sistema con
# pacman -Syu
si saranno sicuramente accorti che l’operazione è stata interrotta da questo messaggio:
errore: impossibile preparare l'operazione
errore: impossibile eseguire l'operazione richiesta (file in conflitto)
xorg-server: /usr/lib/xorg/modules/extensions/libdri.so è già presente nel filesystem
xorg-server: /usr/lib/xorg/modules/libwfb.so è già presente nel filesystem
Si sono verificati degli errori, nessun pacchetto è stato aggiornato.

Bene, lanciando $ pacman -Q xorg-server scopriremo che la versione di xorg-server è sicuramente minore di 1.6 (nel mio caso 1.5.3-5)

Per risolvere il problema in un batter d’occhio basta forzare l’aggiornamento con
# pacman -Sf xorg-server
in questo modo verranno anche sovrascritti i file esistenti di cui parlava l’errore.

Ora si può tranquillamente continuare all’aggiornamento del sistema 😀

Written by alechx

15 aprile 2009 at 09:47

Pubblicato su archlinux, informatica

Tagged with ,

Facebook…

with one comment

Ciao a tutti ragazzi!
Oggi vi faccio un bel pesce d’aprile!!!
MI ISCRIVO A FACEBOOK!
(…anzi mi sono appena iscritto…d’oh)

Molti di voi, che mi conoscono, sanno che fino alla fine ho tenuto duro con quest’iscrizione, ma è giunto il momento di unirmi ai circa 200.000.000 di utenti di questo social network che ha saputo avvicinare a internet anche persone che sapevano a malapena accendere un pc…

Infondo mi sono iscritto per diventare fan di Shakira!!! 😀

Written by alechx

1 aprile 2009 at 00:01

Pubblicato su altro

Tagged with